import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<url>(?:https?:\\/\\/)?(?:[^@\\/\\n]+@)?(?:www\\.)?(?P<domain>[^:\\/?\\n]+))/*.*";
final String string = "http://google.com/sldjakdjadlkf\n"
+ "https://www.yahoo.com/dkajldakjfdk?dajfdlkfdj_=$\n"
+ "https://www.bing.com\n"
+ "https://google.com.in/dlajfkdlakdffd\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}