using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div dir=""ltr"">+359877202870</div>";
string input = @"<a style='margin:12px; margin-left:13px'><p style='margin-top:13px'></p>Margin</a> Hello margin top <p margin:13><p style='margin:123;margin-right:12px'><margin></p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}