$re = '/<div dir="ltr">+359877202870</div>/i';
$str = '<a style=\'margin:12px; margin-left:13px\'><p style=\'margin-top:13px\'></p>Margin</a> Hello margin top <p margin:13><p style=\'margin:123;margin-right:12px\'><margin></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);