import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div dir=\"ltr\">+359877202870</div>";
final String string = "<a style='margin:12px; margin-left:13px'><p style='margin-top:13px'></p>Margin</a> Hello margin top <p margin:13><p style='margin:123;margin-right:12px'><margin></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}