using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bGO_VERSION[\s\S]+?""(?<currentValue>.+?)""";
string input = @"[build.environment]
GO_VERSION = ""1.22.2""
HUGO_VERSION = ""0.126.0""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}