const regex = /\bGO_VERSION[\s\S]+?"(?<currentValue>.+?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bGO_VERSION[\\s\\S]+?"(?<currentValue>.+?)"', 'gm')
const str = `[build.environment]
GO_VERSION = "1.22.2"
HUGO_VERSION = "0.126.0"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}