re = /\bGO_VERSION[\s\S]+?"(?<currentValue>.+?)"/m
str = '[build.environment]
GO_VERSION = "1.22.2"
HUGO_VERSION = "0.126.0"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end