import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*<result>(?P<result>.+)</result>\\s*$|^\\s*<code>(?P<code>\\d+)</code>\\s*$|^\\s*<description>(?P<description>(.|\\n)*)</description>\\s*$|^\\s*<status>(?P<status>.*)</status>\\s*$";
final String string = "<?xml version=\"1.0\" ?>\n"
+ "<reply>\n"
+ " <result>ERROR</result>\n"
+ " <code>1</code>\n"
+ " <status>Not Delivered</status>\n"
+ " <description>failed to send 1 message</description>\n"
+ " <message_infos>\n"
+ " <message_info>\n"
+ " <phone>79051112233</phone>\n"
+ " <sms_id>1000472891</sms_id>\n"
+ " </message_info>\n"
+ " </message_infos>\n"
+ "</reply>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}