# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*<result>(?P<result>.+)</result>\s*$|^\s*<code>(?P<code>\d+)</code>\s*$|^\s*<description>(?P<description>(.|\n)*)</description>\s*$|^\s*<status>(?P<status>.*)</status>\s*$"
test_str = ("<?xml version=\"1.0\" ?>\n"
"<reply>\n"
" <result>ERROR</result>\n"
" <code>1</code>\n"
" <status>Not Delivered</status>\n"
" <description>failed to send 1 message</description>\n"
" <message_infos>\n"
" <message_info>\n"
" <phone>79051112233</phone>\n"
" <sms_id>1000472891</sms_id>\n"
" </message_info>\n"
" </message_infos>\n"
"</reply>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.