const regex = new RegExp('^\\s*<result>(?P<result>.+)</result>\\s*$|^\\s*<code>(?P<code>\\d+)</code>\\s*$|^\\s*<description>(?P<description>(.|\\n)*)</description>\\s*$|^\\s*<status>(?P<status>.*)</status>\\s*$', 'gm')
const str = `<?xml version="1.0" ?>
<reply>
<result>ERROR</result>
<code>1</code>
<status>Not Delivered</status>
<description>failed to send 1 message</description>
<message_infos>
<message_info>
<phone>79051112233</phone>
<sms_id>1000472891</sms_id>
</message_info>
</message_infos>
</reply>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}