#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<MicGainText>\d+)\sdB"
Local $sString = "18 dB, 16 dB, 12 dB, 12 dB, 12 dB, 13 dB, 4 dB, 8 dB, 9 dB, 9 dB" & @CRLF & _
"9 dB, 9 dB, 9 dB, 9 dB" & @CRLF & _
"9 dB" & @CRLF & _
"9 dB, 9 dB, 9 dB, 9 dB, 9 dB" & @CRLF & _
"7 dB, 9 dB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")