re = /(?<MicGainText>\d+)\sdB/m
str = '18 dB, 16 dB, 12 dB, 12 dB, 12 dB, 13 dB, 4 dB, 8 dB, 9 dB, 9 dB
9 dB, 9 dB, 9 dB, 9 dB
9 dB
9 dB, 9 dB, 9 dB, 9 dB, 9 dB
7 dB, 9 dB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end