// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<MicGainText>\d+)\sdB").unwrap();
let string = "18 dB, 16 dB, 12 dB, 12 dB, 12 dB, 13 dB, 4 dB, 8 dB, 9 dB, 9 dB
9 dB, 9 dB, 9 dB, 9 dB
9 dB
9 dB, 9 dB, 9 dB, 9 dB, 9 dB
7 dB, 9 dB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}