import re
regex = re.compile(r"(.|\s)*duplicates value on record with id(.|\s)*", flags=re.MULTILINE)
test_str = ("com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of `java.util.LinkedHashMap<java.lang.Object,java.lang.Object>` out of START_ARRAY token\n"
" at [Source: (String)\"[{\"message\":\"duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8\",\"errorCode\":\"DUPLICATE_VALUE\",\"fields\":[]}]\"; line: 1, column: 1]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")