using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!<span>)highlighted(?!<\/span>)";
string input = @"highlighted <span>highlighted</span> highlighted some <something>highlighted</something>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}