$re = '/(?<!<span>)highlighted(?!<\/span>)/';
$str = 'highlighted <span>highlighted</span> highlighted some <something>highlighted</something>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);