re = /(?<!<span>)highlighted(?!<\/span>)/
str = 'highlighted <span>highlighted</span> highlighted some <something>highlighted</something>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end