using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<src>(?!\.\/assets\/)";
string input = @"<src>../../......</src> -- match
<src>./assets/</src> -- no match
<src>bla/bla/bla</src> -- match";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}