re = /<src>(?!\.\/assets\/)/
str = '<src>../../......</src> -- match
<src>./assets/</src> -- no match
<src>bla/bla/bla</src> -- match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end