// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?<sup_all>
(?:
(?<!\\)\^
(?<sup_text>
(?>\\[\^[:blank:]\h]|[^\^[:blank:]\h\v])*+
)
(?<!\\)\^
)
|
(?: # or the Microsoft way. Beurk
\<sup\>
(?<sup_text>
((?!\v).)+
)
\<\/sup\>
)
)").unwrap();
let string = "2^10^ is 1024.
Space is not allowed:
P^a cat^
But it's ok if it is escaped
P^a\\ cat^
Line break is a no-no, even escaped
P^a\\
cat^
Hmm <sup>This is a Microsoft superscript!</sup>
H^2^0
text^a\\ superscript^
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}