const regex = /^(?:\w{3},)*\w{3}(?=\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\w{3},)*\\w{3}(?=\\w)', 'gm')
const str = `abcd
`;
const subst = `$&,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);