$re = '/^(?:\w{3},)*\w{3}(?=\w)/m';
$str = 'abcd
';
$subst = "$&,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;