use strict;
my $str = 'abcd
';
my $regex = qr/^(?:\w{3},)*\w{3}(?=\w)/mp;
my $subst = '$&,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";