using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[quote\](?:(?1)|.)*?\[/quote])(*SKIP)(*F)|@\w+";
string input = @"@friends @john [quote]@and @jane[/quote] @doe";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}