const regex = new RegExp('(\\[quote\\](?:(?1)|.)*?\\[/quote])(*SKIP)(*F)|@\\w+', 'gs')
const str = `@friends @john [quote]@and @jane[/quote] @doe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}