package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\[quote\](?:(?1)|.)*?\[/quote])(*SKIP)(*F)|@\w+`)
var str = `@friends @john [quote]@and @jane[/quote] @doe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}