// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div class="textPremium">Premium Access (.*) \| (.*)<br\s*/?>Server: ON \| Bandwidth: (.*)MB<br\s*/?></div>"#).unwrap();
let string = "<div class=\"textPremium\">Premium Access 25.04.2014 | 20:59<br>Server: ON | Bandwidth: 200MB<br /></div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}