import Foundation
let pattern = #"<div class="textPremium">Premium Access (.*) \| (.*)<br\s*/?>Server: ON \| Bandwidth: (.*)MB<br\s*/?></div>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<div class="textPremium">Premium Access 25.04.2014 | 20:59<br>Server: ON | Bandwidth: 200MB<br /></div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}