#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^heading1\n((?:.+\n)*)"
Local $sString = "heading1" & @CRLF & _
"foo=bar" & @CRLF & _
"baz=qux" & @CRLF & _
"" & @CRLF & _
"heading2" & @CRLF & _
"spam=ham" & @CRLF & _
"" & @CRLF & _
"heading3" & @CRLF & _
"this=that"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")