re = /^heading1\n((?:.+\n)*)/m
str = 'heading1
foo=bar
baz=qux
heading2
spam=ham
heading3
this=that'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end