$re = '/^heading1\n((?:.+\n)*)/m';
$str = 'heading1
foo=bar
baz=qux
heading2
spam=ham
heading3
this=that';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);