#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^:]*:\s*([^?]+\?)\s+(?:\([^()]*\)?\s)?(.*)"
Local $sString = "Task 1: Question 1? answer1" & @CRLF & _
"Task 2: Question 2? (Format:****) answer2" & @CRLF & _
"Task 3: Question 3? answer3" & @CRLF & _
"Task 4: Question 4? (Format:*****) answer4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")