$re = '/^[^:]*:\s*([^?]+\?)\s+(?:\([^()]*\)?\s)?(.*)/m';
$str = 'Task 1: Question 1? answer1
Task 2: Question 2? (Format:****) answer2
Task 3: Question 3? answer3
Task 4: Question 4? (Format:*****) answer4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);