import re
regex = re.compile(r"^[^:]*:\s*([^?]+\?)\s+(?:\([^()]*\)?\s)?(.*)", flags=re.MULTILINE)
test_str = ("Task 1: Question 1? answer1\n"
"Task 2: Question 2? (Format:****) answer2\n"
"Task 3: Question 3? answer3\n"
"Task 4: Question 4? (Format:*****) answer4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")