$re = '/^-.+/m';
$str = '-1 match test (0123)=??.,
rest of first match (should be in splitted 1 match value)
- second match test ()=??.,
- third match
-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);