re = /^-.+/m
str = '-1 match test (0123)=??.,
rest of first match (should be in splitted 1 match value)
- second match test ()=??.,
- third match
-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end