// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-.+").unwrap();
let string = "-1 match test (0123)=??.,
rest of first match (should be in splitted 1 match value)
- second match test ()=??.,
- third match
-
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}