#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[^;]*|\G)[;\h]*(\b\d+|$)"
Local $sString = "Name-6.1.4_Float Time;453802;464204;466345 464481 466131 464283 465065 462561" & @CRLF & _
"Name-6.1.4_Logic Good Time;125896;145349;137303 131601 144520 132487 133884"
Local $sSubst = "$1;$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)