using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^;]*|\G)[;\h]*(\b\d+|$)";
string substitution = @"$1;$2";
string input = @"Name-6.1.4_Float Time;453802;464204;466345 464481 466131 464283 465065 462561
Name-6.1.4_Logic Good Time;125896;145349;137303 131601 144520 132487 133884";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}