re = /(^[^;]*|\G)[;\h]*(\b\d+|$)/m
str = 'Name-6.1.4_Float Time;453802;464204;466345 464481 466131 464283 465065 462561
Name-6.1.4_Logic Good Time;125896;145349;137303 131601 144520 132487 133884'
subst = '$1;$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result