#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(Conv2d)\((\d+),\s(\d+),\skernel_size=\((\d+),\s(\d+)\),\sstride=\((\d+),\s(\d+)\),\spadding=\((\d+),\s(\d+)\)\)"
Local $sString = "Conv2d(3, 64, kernel_size=(3, 3), stride=(1, 1), padding=(1, 1))" & @CRLF & _
"Conv2d(64, 128, kernel_size=(3, 3), stride=(1, 1), padding=(1, 1))"
Local $sSubst = "\1(\2 -> \3, \4x\5, \6,\7,\8,\9)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)