re = /(Conv2d)\((\d+),\s(\d+),\skernel_size=\((\d+),\s(\d+)\),\sstride=\((\d+),\s(\d+)\),\spadding=\((\d+),\s(\d+)\)\)/
str = 'Conv2d(3, 64, kernel_size=(3, 3), stride=(1, 1), padding=(1, 1))
Conv2d(64, 128, kernel_size=(3, 3), stride=(1, 1), padding=(1, 1))'
subst = '\\1(\\2 -> \\3, \\4x\\5, \\6,\\7,\\8,\\9)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result