import re
regex = re.compile(r"(Conv2d)\((\d+),\s(\d+),\skernel_size=\((\d+),\s(\d+)\),\sstride=\((\d+),\s(\d+)\),\spadding=\((\d+),\s(\d+)\)\)")
test_str = ("Conv2d(3, 64, kernel_size=(3, 3), stride=(1, 1), padding=(1, 1))\n"
"Conv2d(64, 128, kernel_size=(3, 3), stride=(1, 1), padding=(1, 1))")
subst = "\\1(\\2 -> \\3, \\4x\\5, \\6,\\7,\\8,\\9)"
result = regex.sub(subst, test_str)
if result:
print(result)