const regex = /.*"(?:GET|HEAD|OPTIONS|TRACE|CONNECT|PATCH)\s+[^"]*"\s+(?:-)?(\d+)?\s+(\d+).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*"(?:GET|HEAD|OPTIONS|TRACE|CONNECT|PATCH)\\s+[^"]*"\\s+(?:-)?(\\d+)?\\s+(\\d+).*', '')
const str = `28.4.27.6 - - [24/Jul/2016:22:39:57 -0700] "GET /em/faces/consoleStatus.jsp HTTP/1.1" 302 53301 [ecid: 1.0000Kmv_oiW1NeP5If_Aif1LBVVM00000L;kXhgv0ZGZKSULGSPXKTPJHSRo4USpLO] [User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3) OracleEMAgentURLTiming/3.0]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}