# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\"(?:GET|HEAD|OPTIONS|TRACE|CONNECT|PATCH)\s+[^\"]*\"\s+(?:-)?(\d+)?\s+(\d+).*"
test_str = "28.4.27.6 - - [24/Jul/2016:22:39:57 -0700] \"GET /em/faces/consoleStatus.jsp HTTP/1.1\" 302 53301 [ecid: 1.0000Kmv_oiW1NeP5If_Aif1LBVVM00000L;kXhgv0ZGZKSULGSPXKTPJHSRo4USpLO] [User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3) OracleEMAgentURLTiming/3.0]"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.