using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[start](?:(?!\[(?:start|end)]).)*\[end]";
string input = @"Hello ""world"". [start]this is
a ""mark""[end]. It should work with [start]""several"" ""marks""[end]";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}