$re = '/\[start](?:(?!\[(?:start|end)]).)*\[end]/s';
$str = 'Hello "world". [start]this is
a "mark"[end]. It should work with [start]"several" "marks"[end]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);