re = /\[start](?:(?!\[(?:start|end)]).)*\[end]/
str = 'Hello "world". [start]this is
a "mark"[end]. It should work with [start]"several" "marks"[end]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end