package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`src=\"(?P<src>img\/programacao\/[^\"]+)\"`)
var str = `"<img src="img/programacao/51.jpg" style="width:200px;" /><p>balbalba</p><img src="img/programacao/46.jpg" style="width:200px;" /><p>balbalba</p><img src="/img/finalCinerio.jpg"><p>balbalba</p><img src="img/topo.jpg" />"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}