// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"src=\"(?P<src>img\/programacao\/[^\"]+)\""#).unwrap();
let string = "\"<img src=\"img/programacao/51.jpg\" style=\"width:200px;\" /><p>balbalba</p><img src=\"img/programacao/46.jpg\" style=\"width:200px;\" /><p>balbalba</p><img src=\"/img/finalCinerio.jpg\"><p>balbalba</p><img src=\"img/topo.jpg\" />\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}